• 992 Players on Java
  • us.mineplex.com
  • 7106 Players Online
  • 6114 Players on Bedrock
  • pe.mineplex.com
!
Attention Internet Explorer Users
To have the best user experience on our site please consider upgrading to Google Chrome or Mozilla Firefox

Why mineplex should update to a newer version of minecraft

Discussion in 'General Idea Discussion' started by Krystal The Fox, May 9, 2021.

  1. Disclaimer: Please don't be negative about this discussion as it's just a discussion as an update may or may not happen at all.

    As you may know mineplex has been using 1.8.9 for over 6 years now and it's time for a change for the server. The 1.8 release from late 2014 is not as good being used in 2021 as many of the features in 1.8 aren't as good as in comparison to newer versions. I thinks its time to move on from 1.8 and update to at most 1.12 as any newer than 1.12 will cause a lot of issues. You see, 1.8 is over 7 years old in 2021 and about 97% of other minecraft servers no longer support 1.8. The reason that 1.8 is no longer support on most servers is that 1.8 lacks feature in newer and stable minecraft releases like 1.12 for example. Also, 1.8 is at the end of it's useful life. Although many people dislike the new combat features in newer versions, many plugins convert the pvp mechanics to match 1.8 pvp mechanics. Just because pvp is different in newer versions, doesn't mean it ruins minecraft servers. There are many unique features that can improve minecraft servers with newer versions. For Example, newer versions fixed long existing bugs for 1.8 and older. Also, in newer versions, new and unique combat techniques can improve pvp by a lot and make a better game for everyone. I know it can take getting used to new versions, but once you do, you will enjoy it. anyways, that is why mineplex should update to a newer version of minecraft.
     
    Posted May 9, 2021
    maevestarbaby likes this.
  2. Here are two reasons this will not be happening anytime soon:

    1. The majority of the current player base that is bringing Mineplex the money would not like this at all. 1.8.9 is the last version of acceptable pvp for a lot of people and even if it was changed to normal in future versions (like it is if you try to play on 1.9+), people still would not trust it and would not want to play. There have been many discussions about this but ultimately people would prefer to stay on this version, or at least have it available.

    2. One of the physically biggest problems atm - version issues. There is so many of them. The most stable of the newest versions is 1.14. However play it anyways and see all of the bugs that come with it. Any version after 1.8.9 is not stable enough to become the new lowest version. Try using cosmetics or playing games like SSM. Particles are completely messed up and glitched and don't even get me started on audio...These might seem like small things that are easily fixed, but at a certain point they really cannot be with how Mineplex is currently. These things heavily weigh down new updates and would be terrible for the server if 1.8 was completely removed.

    I think that at some point, Mineplex will definitely have to let go of 1.8, as plenty of other servers. It would definitely be great in a way, there would be so many new possibilities and blocks we could use for games, maps, and other things. However, there are simply too many barriers to bring it to light at this time, or anytime soon, for that matter.
     
    Posted May 9, 2021
  3. Bump Bump Bump!
     
    OP OP
    OP OP Posted May 18, 2021
  4. We cannot afford to be making any decisions that could anger or turn away a majority of our playerbase, especially on Java right now. I understand that 1.8 is old, but it's tried and true. Many clients still support it, many people still play on it, and it's not worth removing 1.8 support for some new blocks or features. I have no way to get exact stats, but it's a huge percentage of players who still use 1.8 daily and while some of them might be willing to update versions, others would not and I don't think it's worth taking that risk.
     
    Posted May 18, 2021
  5. The majority of players on java that are in 1.8.9 are as mods have told me before - part of the community and loyal players - the server would cap at 20 players if that were not true. If they are truly loyal, they would switch. There are only 800 of them anyway, compare that to 10k bedrock users that revived no updates, and we have not left.
    As he said in the post, get a mod to fix PvP. There are THOUSANDS.
    We know that there are a lot of versions, because minecraft is updating. Cosmetics? Particles? Just update those as you update the server and have players report in what ones break in future updates. You made them fresh in 1.8.9 without any pre-made things to go off of, you can adapt those into newer things. What is wrong with mineplex currently that would stop these from being easy to fix?

    Now aside from reply's, heres what i think.
    I think its a good idea to update, there are too many future versions and things. Everything can be re-made for new versions, and the player base would adapt. Will the update happen? Nope. 2 Mods have already replied saying no, i doubt it will even reach higher ups. This is just a mineplex issue. I can only think of one issue with updating:
    Most 1.8.9 players are for hypixel. I play java mineplex when i get bored of hypixel after running skyblock for hours on end. If this were not 1.8.9, those bored players would not bother to switch versions to play.
     
    Posted May 18, 2021
  6. -1
    Yeah, I guess it's a good idea but it is factual that the majority plays on 1.8.9 and if the current staff team were to make a change, It would affect the entire server.
    The rest is stated above.
    :bedrock:
    see ya,
    FlamezMC
     
    Posted May 18, 2021
    Orangey likes this.
  7. it should be updated to at least 1.24, maybe 1.26. Not because of the villagers, but because of all the cool new building blocks introduced in 1.14 & 1.16.
     
    Posted May 18, 2021
  8. Does not mean they would switch. They are loyal to how Mineplex is now, in terms of versions. Polls were done, they want 1.8.9 at least available. Many players in the past have also been loyal but after certain updates, or rather lack thereof, they simply left or moved on. We can't completely eliminate the most popular and wanted version to see what happens. We could lose a ton of money.

    As I said - at one point, Mineplex will 1000% have to let go, same with many other servers. But that time is not now. There are too many issues at this moment in time, and different priorities.

    Thousands of what? There are only 100 Moderators give or take, and they don't do a hint of coding. Developers do the coding and develop the server, they would be the ones to fix these issues. However, as of now, there are only 2 back-end Java developers, AlexTheCoder & MorganV. And they have a lot to do

    Well, it's not only that. And as I mentioned in my reply, these aren't very easily fixable. Version issues are more than just broken cosmetics/audio. There are tons of visual bugs and behind the scenes issues which you may or may not experience trying to play on all these new versions. Overtime, many things changed in Minecraft, not just front-end. It's difficult to fix everything and make it work together. It just takes a ton of work. We will be getting new developers this month, hopefully, and these issues will hopefully get tackled. But I still doubt we will move off 1.8.9 anytime soon.
     
    Posted May 19, 2021
  9. I guess that is true lol.
    Thousands of mods to fix pvp, not moderators.
    Thats very true, updating things is hard lol.
     
    Posted May 19, 2021
  10. Ah yes, update to 1.24 or 1.26. The perfect versions, why have we not thought of this before lol?
     
    Posted May 19, 2021
  11. I'm sure this has been addressed but if this were to happen, major development changes in places such as a code base would need to change. I'm not sure if you've played Mineplex on the latest versions but it is VERY buggy. The server is very optimized for 1.8 and it would take a while for developers to make the server run well on 1.16. We also have like 1 dev for Java atm lol so what are you expecting to be done with 1 developer, we all know Mineplex developers take forever to do things anyways. If Mineplex truly wanted to anger it's community it would take this suggestion, but they are not in the place to be doing risky things right now.
     
    Posted May 19, 2021
    maevestarbaby likes this.
  12. Oopd. I meant 1.14 or 1,16. Also, off topic, but why did 1.10 come after 1.9? 2.0 should have. We went from 1.9 to 1.1, technically
     
    Posted May 19, 2021
    CheeseySF likes this.
  13. never thought of it that way.. hmmm
     
    Posted May 19, 2021
  14. hold shift with a shield and click 1 cps.
    very good pvp
    +100000
     
    Posted May 20, 2021
  15. Seems unlikely. A huge portion of the playerbase plays 1.8 exclusively and is not going to be willing to swap. There is not a plugin that properly imitates 1.8 pvp and given Mojang's apparently cluelessness regarding pvp, I don't see a newer version of the game working for large servers. People have made it abundantly clear that they prefer 1.8 pvp and attempting to imitate that in a newer version really just hasn't ever taken off for a reason. You'd also have to find a way to get all the mods that people like that exist in 1.8 to work in whatever version you're updating to, and convince players that it's worth changing versions in their launcher whenever they want to play on Mineplex.

    lol no I'm gone if this happens.
     
    Posted May 20, 2021
  16. Ha true i guess
     
    Posted May 20, 2021

Share This Page