• 1393 Players on Java
  • us.mineplex.com
  • 10413 Players Online
  • 9020 Players on Bedrock
  • pe.mineplex.com
!
Attention Internet Explorer Users
To have the best user experience on our site please consider upgrading to Google Chrome or Mozilla Firefox

1.12+ or even 1.16 with 1.8 combat

Discussion in 'Server Discussion' started by THE_JD, Sep 25, 2020.

  1. "
    Hello!

    Switching to a higher version would not be in our best interest. It would open up new opportunities for game functionality and map design, and we are able to revert the PvP changes internally, but a large portion of our playerbase would be unhappy with such a change. Many players are accustomed to 1.8, and there are a few clients/mods that only run on that version. For those reasons, I'll be denying this idea and locking the thread.

    Thanks for posting. I encourage you to continue sharing your ideas. If you have questions, my messages are open."

    -ssnip

    I heard that 2 weeks from now, lunar client will be making 1.12+ versions of their client and they have been working on it for 3+ months

    Also, i found a list mod avalilable for 1.12+, some of them even better then their 1.8 versions of themselves, but i cant really link them
     
    Posted Sep 25, 2020
    StyxKiller03 likes this.
  2. So, when lunar client decides to do that, will mineplex be able to make the jump( but slowly)?
    At first, only the building blocks will be affected meaning u can't obtain 1.9+ items,or mobs
    that way, we can let 1.8 tryhard adapt
    Also, we should make a "1.12 realm" of the minigames
     
    OP OP
    OP OP Posted Sep 25, 2020
  3. no -1
     
    Posted Sep 25, 2020
  4. I’m honestly confused... Also, I would ask you to wait until someone has responded and you could’ve included the #2 thread to your #1 thread.
     
    Posted Sep 25, 2020
  5. This has been brought up many times, and although it sounds like a good in theory, it really isn't. Here are a few things to consider:

    1) There are many irreversible changes made to the Minecraft client that the server has no control over, with many of them stifling PvP explicitly when there is no hit cooldown present. If you ever played Skyfall when it was out, it was very noticeable because Mineplex had no control over the changes which negatively impacted Mineplex's PvP system specially. Not everyone is willing to use Lunar, and even if it did truly keep the PvP system consistent with 1.8, it wouldn't be a level playing field against people not using it.

    2) Mojang continues to care little to none about larger Minecraft servers and newer Minecraft versions do not perform even close to as well as 1.8 and previous versions do, to any degree. If you already find that there is too much lag on Mineplex after 6 years worth of optimizations to specifically 1.8, then you will definitely see that new versions, especially after 1.13 will blow the current amount of lag out of the water. Leading into the next point,

    3) The entire Mineplex codebase is written to operate on Spigot for 1.8, likely including modifications to Spigot itself. Moving to a newer version is now a massive investment between 2 consecutive major releases, and this entails that Mineplex steps all the way from 1.8 to at least 1.12. Mineplex has implemented content available in 1.9+ on their server while still running 1.8 before (Elytras/Skyfall), but even then, Elytras are a very simple concept under the hood. Implementing new content as it is comes out is a never-ending battle. Mojang has completely dropped backwards compatibility with many parts of the game that were previously kept such as loading worlds which can have some very obtuse effects.

    [​IMG]


    As a final remark, Mineplex already has a relatively small playerbase at the moment. Even if there is a ton of new things possible using new content introduced in newer Minecraft versions, it would still be purging out 6 years worth of modification development on 1.8 including many optimizations to the game. It is clear that Mojang is not really on board with larger-scale Java Edition servers as they used to be, especially with their refusal to add an option to switch between PvP systems (which would be a walk in the park with their development team). The multiplayer community is currently doing fine on 1.8, even if Mineplex isn't relatively doing as well. Moving up to a new version would only hurt Mineplex.
     
    Posted Sep 25, 2020
    StyxKiller03 likes this.
  6. So,if a server wants to do this, they must be new or something?
     
    OP OP
    OP OP Posted Sep 25, 2020
  7. I mean making a 1.12 version of the server with the proper 1.8 plugins and proper plugin support
     
    OP OP
    OP OP Posted Sep 25, 2020
  8. So they will be both a full 1.8 and a 1.12 with proper plugins
     
    OP OP
    OP OP Posted Sep 25, 2020
  9. uwu
     
    Posted Sep 25, 2020
  10. Let’s say the admins agree and want to undertake the challenge because Howe love hard challenge.
    Then what should they do first?
     
    OP OP
    OP OP Posted Sep 25, 2020
  11. Also, reminder:
    Mineplex is a official partner to mojang
     
    OP OP
    OP OP Posted Sep 25, 2020
  12. I honestly think stuff should just be left alone for now cause I see no problems or issues with how it is
     
    Posted Sep 25, 2020
  13. Oh man, I really want Mineplex to change to a newer version, maybe 1.12 or 1.13!
     
    Posted Sep 26, 2020

Share This Page